自定义JS代码注意事项

因主题目前调用的是WP自带的jQuery,最新版的是jQuery 3.5.1,如果通过添加自定义JS代码,实现一些功能,请将类似的:

$(document).ready(function() {

改为:

jQuery(document).ready(function($){

或者尝试将JS代码中:

$符号改jQuery

不想调用WP自带的jQuery

主题目前支持jQuery 1.x版1.12.4版及jQuery 2.x版2.2.4,jQuery 3.x不能使用。

jQuery官网CDN

1、可以下载其它版本的jquery.min.js,放到主题begin\js目录中。

推荐用jQuery v1.12.4

2、打开begin\inc目录的theme-setup.php,查找:

wp_enqueue_script('jquery');

替换为:

wp_deregister_script( 'jquery' );
wp_register_script( 'jquery', get_template_directory_uri() . '/js/jquery.min.js', array(), '1.12.4', false );
wp_enqueue_script( 'jquery' );