禁止 WordPress 发送电子邮件通知

知更鸟 WordPress13390阅读模式

默认情况下,当 WordPress 有新用户注册或用户更改密码和电子邮件地址,WordPress 会发送电子邮件通知管理员或者用户。

文章源自知更鸟-https://zmingcx.com/disable-wordpress-from-sending-email-notifications.html

禁止 WordPress 发送电子邮件通知

禁止 WordPress 发送电子邮件通知

文章源自知更鸟-https://zmingcx.com/disable-wordpress-from-sending-email-notifications.html

如果不需要邮件通知,可以将下面代码添加到主题函数模板 functions.php中:文章源自知更鸟-https://zmingcx.com/disable-wordpress-from-sending-email-notifications.html

// 禁止用户注册时发送电子邮件给管理员
add_filter( 'wp_new_user_notification_email_admin', '__return_false' );

// 禁止重置密码时发送电子邮件给管理员
add_filter( 'wp_password_change_notification_email', '__return_false' );

// 禁止用户注册时发送电子邮件给注册者
add_filter( 'wp_new_user_notification_email', '__return_false' );

// 禁止邮箱地址改变时发送禁止给注册者
add_filter( 'send_email_change_email', '__return_false' );
 
// 禁止更改密码时发送电子邮件给注册者
add_filter( 'send_password_change_email', '__return_false' );

一般仅禁止发给管理员的邮件即可。文章源自知更鸟-https://zmingcx.com/disable-wordpress-from-sending-email-notifications.html 文章源自知更鸟-https://zmingcx.com/disable-wordpress-from-sending-email-notifications.html

weinxin
版权声明
本站原创文章转载请注明文章出处及链接,谢谢合作!
评论  13  访客  10  作者  3
    • 简单生活
      简单生活 4

      每天学到一点点….

      • 遇见台儿庄
        遇见台儿庄 5

        终于能访问了 :wink:

        • 夜未央
          夜未央 3

          鸟哥,能不能写一篇关于wordpress后台推荐更新php到7.4以上版本建议的帖子呢?

            • 知更鸟
              知更鸟

              @ 夜未央 关掉提示?这个真没什么可写的,右上角“显示选项”,取消“建议更新PHP版本”勾选

                • 夜未央
                  夜未央 3

                  @ 知更鸟 其实我是想让你解读下有没有必要升级到PHP7.4或8.*版本,升级后优势真的有说的那么明显吗?还有假如升级到8.2会不会有主题兼容性问题。写个博客大多数人没有折腾的能力,优先考虑稳定,服务器环境以稳定为主,兼顾效率。

                    • 知更鸟
                      知更鸟

                      @ 夜未央 主题兼容PHP8,我自己用的就是,至于评测优势俺还真没这技术

                        • 缩头乌龟小飞
                          缩头乌龟小飞 0

                          @ 知更鸟 搭车问一句 升级了PHP8.1.9,只要404情况就会报错!PHP Warning: Attempt to read property “term_id” on null in /www/wwwroot/xxx.com/wp-includes/class-wp-query.php on line 3903 大佬求解!

                            • 知更鸟
                              知更鸟

                              @ 缩头乌龟小飞 估计用的主题不兼容PHP8,换个主题试试吧

                              • imsong
                                imsong 4

                                @ 缩头乌龟小飞 你用php8.0吧,那个没报错,速度还快。别用wpjam插件,我用那个插件搞得数据库重新建立都装不了wordpress了。恢复都恢复不了。

                        • 简单生活
                          简单生活 4

                          @ 夜未央 还是7.4吧,就算主题不拉跨插件会拉跨! :mrgreen:

                            • 轨魅网
                              轨魅网 2

                              @ 简单生活 :evil: 为什么我升级7.4就会拖垮速度呢?目前在7.3不打算升了。

                                • 简单生活
                                  简单生活 4

                                  @ 轨魅网 这么夸张?我一直用7.4好好的,也是很多主题作者推荐的版本,前几天折腾到8.1.9了,自己修复了两三个报错。

                              • 轨魅网
                                轨魅网 2

                                @ 夜未央 升级以后拖垮速度。

                            匿名

                            发表评论

                            匿名网友 填写信息

                            :?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen:

                            确定