phpStudy 2016 (支持PHP7)使用教程

  • A+
所属分类:WordPress

对学习PHP的新手来说,WINDOWS下PHP环境配置是一件很困难的事,就是老手也是一件烦琐的事。因此,无论你是新手还是老手,phpStudy 2016都是一个不错的选择,该程序集成Apache+PHP+MySQL+phpMyAdmin+ZendOptimizer,最新版本已集成最新的 PHP7
phpStudy 2016 (支持PHP7)使用教程

下面针对刚接触WordPress,并准备学习WordPress使用及个性化修改主题的童鞋,说一下phpStudy程序的使用方法,供大家参考。

本地搭建PHP环境并安装运行WordPress,是喜欢折腾的童鞋所必须的,特别是试用网上淘来的各式各样主题、插件的,更应该在本地环境中测试,否则很多主题、插件都会有数据留在数据库中,后患无穷。

一,下载最新版本phpStudy 2016及相关运行库

必须安装VC运行库,否则不能运行PHP7环境。

该程序包集成最新的Apache+Nginx+LightTPD+PHP+MySQL+phpMyAdmin+Zend Optimizer+Zend Loader,一次性安装,无须配置即可使用,是非常方便、好用的PHP调试环境。该程序绿色小巧简易迷你仅有32M,有专门的控制面板。

二、安装phpStudy程序

将下载的phpStudy程序解压到某个分区的根目录中,第一次使用会提示你初始化一下:

phpStudy 2016 (支持PHP7)使用教程

之后在主控制界面点击启动即可。

phpStudy 2016 (支持PHP7)使用教程

三,新建一个数据库

在浏览器址栏中输入:http://localhost/phpmyadmin/

进入数据库管理工具登录页面,用户名及密码都是:root

phpStudy 2016 (支持PHP7)使用教程

进入数据库管理工具页面后,点击右上角的数据库,在新建数据库中输入:wp(名称可任意),整理选择:utf8_general_ci,如图:

phpStudy 2016 (支持PHP7)使用教程

四,下载安装最新WordPress程序

将下载的WordPress程序解压后,将里面的WordPress文件夹复制到 X:\phpStudy\WWW目录中。

修改WordPress文件夹中的wp-config-sample.php程序文件名称为wp-config.php,之后用专门的编辑软件(比如:Notepad++)打开并编辑其中的内容:

只需要修改这三项:

/** WordPress数据库的名称 */

/** MySQL数据库用户名 */

/** MySQL数据库密码 */

数据库名称为:wp

数据库用户名和密码都是:root

需要注意的是前后不能有空格,如图:

phpStudy 2016 (支持PHP7)使用教程

五、完成WordPress程序安装

在浏览器址栏中输入:http://localhost/wordpress/

会看到wordpress的安装界面,输入相关信息完成安装。

phpStudy 2016 (支持PHP7)使用教程

六,切换PHP版本

在phpStudy主界面上点击PHP版本,进入PHP版本及不同环境组合选择界面

phpStudy 2016 (支持PHP7)使用教程

选择之后,点击应用按钮,phpStudy会自动重启服务并切换到你选择的环境。

另外,如果phpstudy提示80端口和3306端口被占用,可以尝试用下面的方法解决

控制面板->管理工具->服务

找到: World wide web publishing service服务

右击->停止,然后,双击->禁用

weinxin
我的微信
分享交流WordPress经验与技巧,关注前端设计与网站制作。仅用于功能演示。
Begin主题购买
Begin主题购买

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen:

目前评论:32   其中:访客  30   博主  2

    • avatar 路易大叔 6

      这次更新很大啊

      • avatar chwguo 1

        貌似从官网下载的还是2014版本,这里提供的马上测试一下看看是否为2016版

          • avatar chwguo 1

            @chwguo 支持,是2016版

          • avatar chwguo 1

            测试了,是2016版。支持!

            • avatar chwguo 1

              VC库下载链接失效,请更新

              • avatar 虎子博客 1

                鸟哥主题展示的那个位置把我的网站加上去吧, :mrgreen:

                • avatar 点思博客 2

                  复制楼上的话:鸟哥主题展示的那个位置把我的网站加上去吧! :oops: 谢谢!

                  • avatar 上谷歌 4

                    这个技巧很有用 感谢分享

                    • avatar boke112导航 5

                      这个工具挺给力的,平时我就用WampServer,感觉还行

                      • avatar 好文章 4

                        鸟哥新年好、拜个晚年

                        • avatar 静思科技 2

                          看看来,学习了

                          • avatar 迅雷会员分享 0

                            鸟哥新年好啊!

                            • avatar 李光春 2

                              这软件好 :grin:

                              • avatar 寅春树 0

                                api-ms-win-crt-runtime-l1-1-0.dll没有被热量定在windows上运行,但我明明有这个文件

                                • avatar 大城小我 3

                                  很相信,很全面,收藏收藏

                                  • avatar tumblr 福利 6

                                    这个确实是很好的东西 不错

                                    • avatar 林小屋 1

                                      这个用做本地调试的确很好。

                                      • avatar 睿客网 1

                                        phpstudy2016没有php5.6的版本,该怎么手动添加,有教程吗?

                                        • avatar kaikai 0

                                          请问为什么安装了VC库 每次打开phpstudy还是提示检测不到VC库

                                          • avatar 优享库 1

                                            很好用,本地用来运行php程序

                                            • avatar 优享库 1

                                              就是程序的版本能更新快点就好了

                                              • avatar moqiaoduo 1

                                                phpStudy确实好用,也不用安装,不过稳定性和安全性尚未可知,个人做网站还是可以的

                                                • avatar bin 0

                                                  我安装了v11和v14,但是点击切换为apache/php7n的时候提醒我需要先安装v11或v14, 我明明安装了

                                                  • avatar 预算人网 0

                                                    配置没有那么麻烦吧,我还是不喜欢用这种集成的工具,比较喜欢用绿色的,改配置文件

                                                    • avatar 昵空间 0

                                                      帝国也支持php7.0就好了

                                                      • avatar 豫柱建站vs微平台开发 0

                                                        我成功安装好了php5.6+zendloader版本的,网址:58daohang.top,搜索文章php5.6+zend即可你可以到我的站点看一下如何解决的,我也弄了好久才弄好的! 58daohang.top 我安装过phpstudy后,也遇到了很多问题,关于php5.6+zend解密问题就是个大麻烦,不过最终解决了。能够帮你解决问题,就点赞吧!

                                                        • avatar 趴趴狗 0

                                                          :wink: 看看

                                                          • avatar 趴趴狗 0

                                                            不错不错

                                                            • avatar 优站盒子 1

                                                              什么时候更新一下mysql的版本就好了