禁用火狐plugin-container.exe

2011年07月21日19:09:09 25 23,466

禁用火狐plugin-container.exefirefox 3.6.x以后增加了一个功能,第三方插件的崩溃保护,启动火狐后会多出一个plugin-container.exe进程,是firefox为防止浏览器在运行Flash等第三方插件时造成的假死状况。但同时也带来了一定的问题,比如占用CPU和内存,还会造成浏览器很卡等等,如果看着不舒服那就关了它。

具体操作如下:

在火狐地址栏输入“about:config”进入高级设置页面,上面过滤器(filter)中输入:ipc,将所有项的值:true,全改为false,数字改为10,然后重启firefox即可。 过滤器(filter)的ipc列表如下图:

firefox5.0(其它版本类似)

禁用火狐plugin-container.exe修改后:

禁用火狐plugin-container.exe

weinxin
我的微信
分享交流WordPress经验与技巧,关注前端设计与网站制作。仅用于功能演示。
Begin主题购买
Begin主题购买

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen:

目前评论:25   其中:访客  17   博主  6   引用   2

    • Louis Han 6

      那万一假死是不是就得重启了

      • Kael.Z 7

        最近我也用火狐了

          • 知更鸟 Admin

            @Kael.Z 火狐就好比WP,其它博客程序也不错,最后却纷纷转到WP上
            有什么使用问题网上技术教程一堆,其它浏览器可就差多了,喜欢折腾的主必备之物

              • Kael.Z 7

                @知更鸟 不过有些插件再火狐下不能用,非得跑到IE兼容模式下,悲剧的很~chenpress插件就是个典型的悲剧~

                  • 知更鸟 Admin

                    @Kael.Z 不是火狐的问题,那应该是插件的问题,与中国一些SB网站一样,不符合标准,最适合在IE6下运行

                      • Kael.Z 7

                        @知更鸟 鸟,有什么好的编辑插件?推荐个

                          • 知更鸟 Admin

                            @Kael.Z 木用过编辑插件,貌似很多,功能都差不多
                            本来后台编辑框运行就慢,感觉没什么必要

                  • aladd设计量贩铺 3

                    看到留言框想起来问一声~

                    鸟哥~ 2.4正式版里如何加留言框里的提示语~

                    • neverno 2

                      握手,我也还是在用3.6.X的,新版不感冒~

                        • 知更鸟 Admin

                          @neverno 使用中确实未感觉比老版本好在哪,反倒是使用有些不习惯,不过迟早还是要升级的 

                            • neverno 2

                              @知更鸟 是的~不过3系过后FF也玩版本大跃进,太乱了~~~FF个人一直视为最稳定可靠的浏览器,如此大跃进暂时跟不上,要玩升级控可以玩Chrome Opera。

                                • assassin 1

                                  @neverno @neverno : 版本变化其实没多大影响,我一直在跟最新版本的每夜版,感觉和正式版用起来没太大差别,就是改某些扩展的版本号挺烦人。

                            • ★Extreme★ 4

                              firefox6出来了,不过我还是喜欢Chrome!

                              • wmtimes 7

                                其实很多没用的应该关了。就是没个详细的说明。如果有我一定关闭对我无用的。

                                • 数据恢复培训 4

                                  不得了啊不得了

                                  • lhn 0

                                    谢谢!OK了

                                    • 小李 3

                                      鸟哥,您有空了看下www.gan18.com这个网站分页是怎么回事用的是hotnews2.4的版本。还有就是我在single.php这个文件加加入分享按钮之后就想下载这样打开内容页面整个框架严重左倾,但首页没问题。麻烦鸟哥给看下,qq460149750 我给您帐号密码

                                      • lhn 0

                                        稍微复杂一点的插件,在FF的plugin-container中很容易崩溃,关闭它之后就没问题,说明这个容器管理插件与主程序差距很大,太脆弱。还是IE和Chrome的容器机制比较成熟。

                                        • logo设计教程 1

                                          的确快多了,刚才修改了。谢谢

                                          • 随意博客 1

                                            太强了,感谢鸟哥

                                          • 来自外部的引用: 2

                                            • NBVPS挂vagex复活记 – 想去吧
                                            • NBVPS挂vagex不能看youtube解决方案 | VPS-orz